Funding Delay
Incident Report for Bolt Inc.
Resolved
Root Cause Analysis: Funding Delay

Issue Overview

Bolt customarily submits funding instructions on Monday at 12 PM PT for all transactions captured between 7 PM PT Friday to 7 PM PT Sunday. Bolt submitted funding instructions consistent with this practice on January 20, 2020, but because that date was a bank holiday, transfers were not processed. Bolt resubmitted these instructions on Thursday, January 23rd, and confirmed receipt and correct processing of the same with its banking partner. All merchants should receive their funds within 24 - 72 hours of submission [01/23] based on their receiving bank’s clearing rules.

Timestamps

Jan 20, 12:05 PT: Bolt processes and submits ACH instructions to its banking partner for transactions captured after 7 PM PT on Thursday Jan 16 through 7 PM PT on Sunday Jan 19

Jan 20, 12:20 PT: Bolt receives an unforeseen error message and logs it for review

Jan 21, 15:00 PT: Bolt attempts to corroborate the veracity of the error with its cyclical rejection file notification, notices the absence of a file, and reaches out to its banking partner to troubleshoot

Jan 22, 06:15 PT: Bolt’s banking partner confirms that the rejection file was not generated due to the holiday weekend

Jan 23, 06:33 PT: Bolt is made aware of missing settlements for merchants

Jan 23, 06:54 PT: Bolt initiates its incident response process and begins technical debugging

Jan 23, 09:02 PT: Bolt identifies a mismatch between scheme settlement timelines and its funding instruction timelines for the holiday weekend

Jan 23, 10:45 PT: Bolt resubmits funding instructions from Jan 20 to its banking partner

Jan 23, 10:55 PT: Bolt receives a system generated confirmation notification from its banking partner re: successful receipt of payout instructions

Jan 23, 11:40 PT: Bolt follows up with its banking partner directly to corroborate the system confirmation

Merchant Impact

Funds that should have arrived in merchants’ bank accounts on Wednesday, Jan 22 were delayed by 2 business days. Bolt statements will display these funds as having been transferred on January 20th, 2020 when in fact the transfer occurred on January 23rd, 2020, impacting reconciliation. Only merchants using Bolt’s native payment processing with next-day funding were affected.

Remediation Steps

In order to ensure that this issue does not surface again Bolt has taken the following steps:

1) initiated an audit of its error handling and systemic escalation process
2) implemented a four eye policy on system updates for funding and settlement jobs

If you have any further questions or concerns, please reach out to merchantsupport@bolt.com.
Posted Jan 24, 2020 - 17:12 PST
Monitoring
A fix to the issue has been implemented. Funding for transactions that were captured between 7:00 PM Pacific Time on Thursday, January 16th and 7:00 PM Pacific Time on Sunday, January 19th has been issued and the transfer to your bank is expected to occur tomorrow, Friday, January 24th.

We will follow up with a root cause analysis by the end of the day tomorrow, Friday, January 24th. If you have any questions in the meantime, please reach out to merchantsupport@bolt.com.
Posted Jan 23, 2020 - 13:59 PST
Identified
The cause of the issue has been identified. We are working on resolution and will have another update shortly.

If you have any questions, please reach out to merchantsupport@bolt.com.
Posted Jan 23, 2020 - 11:38 PST
Update
Bolt engineering is continuing to investigate this issue.

We will provide another update shortly; if you have any questions, please reach out to merchantsupport@bolt.com.
Posted Jan 23, 2020 - 09:18 PST
Investigating
Bolt engineering is investigating an issue pertaining to a delay in funding for transactions that occurred between 7:00 PM Pacific Time on Thursday, January 16th and 7:00 PM Pacific Time on Sunday, January 19th. Funding for transactions occurring outside this time frame is unaffected. This issue only impacts merchants using Bolt's native payment processing.

We will keep you updated as we work toward resolution; if you have any questions, please reach out to merchantsupport@bolt.com.
Posted Jan 23, 2020 - 08:22 PST
This incident affected: Merchant Dashboard.