Checkout Button Not Appearing for Some Merchants
Incident Report for Bolt
Postmortem

Incident Date: August 29th, 2022

Incident Overview

On August 29th, 2022, Bolt deployed code to production that resulted in the side cart checkout button not rendering for merchants who bundle their side cart with Webpack. As a result, shoppers would have needed to use the main cart checkout button to place their order. Service returned to normal 2 hours and 44 minutes after the issue was introduced.

Timeline (ET)

  • 2022-08-29 2:05pm ET - Issue Introduced Following Code Deployed to Production
  • 2022-08-29 4:22pm ET - Incident Discovered and Confirmed
  • 2022-08-29 4:49pm ET - Incident Resolved
Posted Sep 14, 2022 - 01:48 UTC

Resolved
Bolt experienced an issue that caused the checkout button to not appear for a subset of merchants. The issue has been resolved and we will provide a root cause shortly. Please reach out to merchantsupport@bolt.com if you have any questions or concerns.
Posted Aug 29, 2022 - 20:57 UTC
This incident affected: Checkout.